Alpha Personal Workstation 500au

Aus NOBAQ
Version vom 8. Mai 2011, 12:46 Uhr von Niki (Diskussion | Beiträge)

(Unterschied) ← Nächstältere Version | Aktuelle Version (Unterschied) | Nächstjüngere Version → (Unterschied)
Wechseln zu: Navigation, Suche

Inhaltsverzeichnis

Allgemeines

DEC PWS.jpg

Im März 2009 hatte ich das Glück und eine Alpha erhalten. Mit CD-ROM Laufwerk und einigermaßen aktueller Hardware habe ich tatsächlich die Chance OpenVMS live ausprobieren zu können.

Hardware

  • Grafikkarte: ELSA GLoria Synergy-8 Compaq
  • SCSI-Controller: Symbios Logic 53C810A
  • Alpha CPU mit 433Mhz
  • ...
>>>show dev
dkb0.0.1.4.0               DKB0        TOSHIBA CD-ROM XM-5602B  1796
dkc0.0.0.1009.0            DKC0               SEAGATE ST34520N  1487
dva0.0.0.0.1               DVA0
ewa0.0.0.3.0               EWA0              00-00-F8-75-36-4B
pkc0.7.0.1009.0            PKC0                  SCSI Bus ID 7
pqa0.0.0.4.0               PQA0                       PCI EIDE
pqb0.0.1.4.0               PQB0                       PCI EIDE

Probleme

System bootet nicht

Es wird ein Monitor und PS/2 Tastatur/Maus angesteckt. Es kommt die Ausgabe der Grafikkarte, das System steckt aber mit einem blauen Bildschirm und wiessem Cursor in der oberen linken Ecke fest.

Womöglich ist SRM (statt AlphaBIOS) aktiviert: Eine Konsole mit 9600,1,n,8 an die erste serielle Schnittstelle (und zur Sicherheit stattdessen Tastatur und Maus abstecken!) sollte SRM offenbaren.

Illegal device detected on primary bus in physical slot 5

Nachdem ich das erste Mal mit serieller Konsole gebootet habe kam ich soweit:

ff.fe.fd.fc.fb.fa.f9.f8.f7.f6.f5.CPU 0 speed is 2.31 ns (433MHz)

ef.ee.ed.ec.eb.f4.ea.e9.e8.e7.e6.e5.e4.
Digital Personal WorkStation 433au
Console V7.2-1 Mar  6 2000 14:47:02
Illegal device detected on primary bus in physical slot 5

Power down the system and remove the unsupported device from slot 5 

Sehr gut, das ist schon mal mehr. An Slot 5 ist bei mir die Grafikkarte gesteckt (ELSA GLoria Synergy-8 Compaq). Ein Ausbau derselbigen brachte mich weiter, das System hat aber nicht gebootet (Abbruch mit STRG+C). Ich lande auf der SRM Console:

ff.fe.fd.fc.fb.fa.f9.f8.f7.f6.f5.CPU 0 speed is 2.31 ns (433MHz)

ef.ee.ed.ec.eb.f4.ea.e9.e8.e7.e6.e5.e4.
Digital Personal WorkStation 433au
Console V7.2-1 Mar  6 2000 14:47:02

CPU 0 booting

(boot dk*0.0.0.1009.0 -flags A)
failed to open dk*0.0.0.1009.0
>>>^C 

Von einem anderen Device bootet das System zwar, will aber nicht fertig starten:

>>>boot dkc
(boot dkc0.0.0.1010.0 -flags A)
block 0 of dkc0.0.0.1010.0 is a valid boot block
reading 16 blocks from dkc0.0.0.1010.0
bootstrap code read in
base = 1d8000, image_start = 0, image_bytes = 2000
initializing HWRPB at 2000
initializing page table at 1ca000
initializing machine state
setting affinity to the primary CPU
jumping to bootstrap code

UNIX boot - Wed Jan 10 16:02:47 EST 2001

Loading vmunix ...
Loading at 0xfffffc0000230000

Sizes:
text = 3751968
data = 671600
bss  = 1130192
Starting at 0xfffffc00004b8dc0

Loading vmunix symbol table ... [1077352 bytes]
No B-cache detected
Alpha boot: available memory from 0xe7e000 to 0x13ffe000
Digital UNIX V4.0G (Rev. 1530); Thu Apr  3 13:10:09 MET DST 2003
physical memory = 320.00 megabytes.
available memory = 305.52 megabytes.
using 407 buffers containing 3.17 megabytes of memory
Digital Personal WorkStation 433au
Firmware revision: 7.2-1
PALcode: UNIX version 1.22-0
pci0 at nexus
tu0: DECchip 21142: Revision: 1.1
tu0 at pci0 slot 3
tu0: DEC TULIP (10/100) Ethernet Interface, hardware address: 00-00-F8-75-36-4B
tu0: console mode: selecting 10BaseT (UTP) port: half duplex
ata0 at pci0 slot 4
ata0: CMD PCI0646
scsi0 at ata0 slot 0
scsi1 at ata0 slot 1
rz8 at scsi1 target 0 lun 0 (LID=0) (TOSHIBA CD-ROM XM-5602B  1796)
isa0 at pci0
gpc0 at isa0
gpc1 not probed
ace0 at isa0
ace1 at isa0
lp0 at isa0
fdi0 at isa0
fd0 at fdi0 unit 0
pci1000 at pci0 slot 8
kernel console: ace0
device_translate: device cannot be translated 'SCSI 0 1010 0 0 0 0 0'
setconf: Bootdevice parser failed to translate bootdevice SCSI 0 1010 0 0 0 0 0.
panic (cpu 0): setconf: bootdevice_parser failed

DUMP: No primary swap, no explicit dumpdev.
          Nowhere to put header, giving up.

halted CPU 0

halt code = 5
HALT instruction executed
PC = fffffc00004baa50

CPU 0 booting
[...]

Das Problem war offenbar, dass die 32-Bit Grafikkarte im 64-Bit PCI Slot 5 gesteckt ist. Nachdem ich sie in einen 32-Bit Slot gesteckt habe, hat alles funktioniert.

panic (cpu 0): setconf: bootdevice_parser failed

Woher der Fehler genau kommt kann ich leider auch nicht sagen. Ich habe jedenfalls den SCSI Controller (Symbios Logic 53C810A) in Slot 2 gesteckt und die Grafikkarte in Slot 3. Nun stecken alle 32-Bit Karten in 32-Bit PCI Slöten; auf einmal bootet das System bis

Digital UNIX Version V4.0 (ws2.xxxxxx.com) console

login:

Zusätzlich erscheint eine X11-Console am angeschlossenen Monitor. Einloggen kann ich mich leider nicht da ich kein root-Passwort habe. Ich werde aber ohnehin OpenVMS installieren.

Passwort zurücksetzen

Das root-Passwort von Digital UNIX kann zurückgesetzt werden.

Wo findet man die "CPU Serial Number"?

Für eine OpenVMS Hobbyist Lizenz benötigt man die "CPU Serial Number". Für OpenVMS Laien wie mich ist es gar nicht so klar was das genau ist und woher man sie bekommt. Ich habe keine Möglichkeit gefunden sie per SRM/Software auszulesen, jedoch befindet sich auf der Rückseite des Gehäuses ein Aufkleber von DEC mit "Model SN" und "Model No" (und weiteren Informationen wie Eingangsspannung). Für die Registrierung der Lizenz wird die Model SN benötigt.

Meine Werkzeuge